TSDS Submission Error - Status Code 405

Description of Issue
  • TSDS Submission Errors report Status Code 405
  • Error report shows records with a Status Code 405, but there is no Error Message
Context
  • Payroll
  • Financials
  • Texas
  • TX TSDS Reporting
Cause

The record doesn't exist on the ODS. 

Resolution
  1. Make sure you are on one of the following Tyler Deploy Releases (or higher), 
    1. 2021.10.0.1746
    2. 2021.11.0.1709
    3. 2021.12.0.1455
    4. 2024.1.0.1160
    5. 2024.2.0.654
  2. Ignore the 405 Error because the record that's erroring doesn't belong on the ODS and never existed there. 


This 405 error scenario will be unique to this first Fall Submission, because of the length of time you would have been Generating and re-Generating, without being able to submit to the ODS.  The Generate is also taking steps to sync your records.  

If you install the correction and still receive a 405 error, please look at the Period Record you're getting the error on.  The Record Type is available from the Submission Errors file in Column B.  The affected employee information is in Column G (Request Payload) - Search for "staffUniqueId" and use the Staff ID to Search the affected Period Record. 

If the ODS Status is Out of Sync and Delete from ODS is check marked on the Period Record, you're getting the 405 error because this record never existed on your ODS, so it can't be deleted. 

You can subsequently confirm that the record does not already exist on your ODS by using the DMC search.Â