Workflow Pending TOA Approval stuck



Description of Issue

Unable to locate TOA workflow record

Record approved still showing in approvals

Transfer of Overpayments record locked

Context
  • Munis
  • Transfer of Overpayments
  • Workflow/Approvals
  • Pending Actions
  • 2018.1
  • 2019.1
Cause

This somewhat rare issue occurs in Munis when a Workflow approval will get stuck in a pending state if the approval has been confirmed or removed, and the record may stay in the Workflow Approvals tile although it is no longer a legitimate approval.

Resolution
  1. Confirm the receipts from the tile or error are already approved and posted using the receipts program. Navigate to General Revenues or Property Revenues>Payment Processing>Receipts. 
  2. Click Search. 
  3. Use the open fields to isolate the receipt(s) in question. Click Accept.
  4. Confirm the Journal Information is populated accordingly with a posting date. If so, continue to step 5.
    1. If not, the Transfer of Overpayment Batch/Record may still need to be posted. Navigate to General Revenues or Property Revenues>Payment Processing>Payments Journal. 
  5. Navigate to System Administration>Workflow Administration>Pending Actions (Administration Mode)
  6. Click Search.
  7. Populate the Process field with TOA and if further information is known, populate accordingly. 
  8. Click Accept.
  9. If there are numerous results, click Browse.
  10. Find the bad record and click Accept. 
  11. Click Delete. 
  12. Click Yes to confirm to delete the bad TOA approval tile from Munis. 
  13. The TOA approval tile should now be removed from the user(s) pending actions. 
Additional Information