NHRS Validation Message - Effective base pay not found

Description of Issue

What is causing this error to occur and the employee not to generate a period record?

Effective base pay not found for Emp: #### Job: ###

Context
  • Payroll

  • New Hampshire

  • NHRS Report

Cause

The program can't find a base pay record for this Job Class code that meets ALL of the following criteria:

  • The Pay codes is not defined as Comp Over Base Pay, or Extra Duty Pay on the Pays tab of the Generate

  • The Effective Date is on or before the End Date of the pay period (based

  • The Position Start date is on or before the End Date of the pay period

  • The Pay Start date is on or before the End date of the pay period

  • The Pay End date is on or after the Begin date of the pay period

Resolution
  1. Review the Pays tab of the NHRS Generate screen to confirm accuracy and update as needed. 

  2. If define is accurate, that indicates that the employee doesn't have a base pay record for this Job Class that was Effective during the pay period. 

    1. This can happen if the pay record in the Payroll was manually added through an Import, or the Add option.

    2. Manually create the missing Period Record for the Check Date in question to move forward.

    3. Moving forward, educate staff with Job/Salary permissions by referencing Employee Job Salary Dates - A Cheat Sheet

Additional Information