Account Inquiry - User cannot see any accounts
Description of Issue
- Account Inquiry search results in zero records returned
- Account Inquiry sees records in search but once accepted display zero records at the bottom with no accounts or amounts displayed
- Account Inquiry only works when a single account is defined but not when more than one is selected
Context
- Account Inquiry
- Segment Sort Order
- Configuration & Setup
- Roles & Permissions
Cause
- User's General Ledger data access is not correctly configured to allow access to accounts being defined through record selection criteria
- Segment Sort Order is not defined as unique to allow system to know what account record to display first
- This can happen if the same option is selected more than once
Resolution
First ensure this is not simply a segment sort order issue before reviewing or adjusting permissions:
- Browse to Enterprise ERP > Financials > General Ledger Menu > Inquiries and Reports > Account Inquiry
- Search
- Sort By SegmentÂ
- Make sure all necessary segments (often Org, Object, Project but can be any 3 segments) are selected. This determines the order that accounts are displayed in when scrolling through the find-set.Â
- Accept
- Now enter account find-set to confirm they display in the expected order.
If issues remain review users data access for assigned GL role permissions from User Attributes
Additional Information