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Description of Issue

Okta 400 Bad request Invalid_Social_Token Received for all Users, No User Can Login

Context
  • OKTA
  • TID-W
  • ADFS
  • EERP
Cause

Expiration of Client Secret or a domain name change causes client secret failure and the error above

Resolution

To renew the Client Secret in Azure AD portal, follow these steps:

1. Sign in to the Microsoft Azure portal.

2. Navigate to Azure Active Directory > App registrations > Owned applications.

3. Select the application.

4.  Certificate & secrets > Client secrets > New client secret.

5. Give a description and an expiration for the Client’s Secret.

 Note: The maximum Client Secret expiration date is 24 months. Even if you select the Custom option, the maximum is 2 years. But with PowerShell, there is no maximum, and you can set any date.

6. Copy the value.

Note: Client secret values cannot be viewed, except for immediately after creation. Be sure to save the Client Secret value when created before leaving the page.

7. Upload a .txt file of the Client Secret to your Kiteworks folder and notify the technician on your support case that it is available to be updated.


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